找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 645|回复: 10

[求助] Python中h5py库告警问题

1

主题

7

帖子

7

积分

贫民

积分
7
进阶的小白 发表于 2017-12-21 15:34:32 | 显示全部楼层 |阅读模式
下载并安装了h5py库,准备使用该库,但是调用该库时总出现warning!,求大神帮忙看一下怎么解决。

h5py告警

h5py告警
回复

使用道具 举报

1

主题

7

帖子

7

积分

贫民

积分
7
进阶的小白  楼主| 发表于 2017-12-22 18:58:31 | 显示全部楼层
有没有大神帮忙看一下啊,万分感激!
回复 支持 反对

使用道具 举报

1

主题

7

帖子

7

积分

贫民

积分
7
进阶的小白  楼主| 发表于 2017-12-26 08:44:44 | 显示全部楼层
再顶一下,求帮忙
回复 支持 反对

使用道具 举报

2

主题

219

帖子

219

积分

版主

Rank: 7Rank: 7Rank: 7

积分
219

热心会员默默耕耘优秀版主

剑心无痕 发表于 2017-12-26 10:15:52 | 显示全部楼层
print(h5py.__version__)是多少,2.7.1无警告
版本低用pip3 install h5py --upgrade 升级
回复 支持 反对

使用道具 举报

1

主题

7

帖子

7

积分

贫民

积分
7
进阶的小白  楼主| 发表于 2017-12-26 15:19:49 | 显示全部楼层
剑心无痕 发表于 2017-12-26 10:15
print(h5py.__version__)是多少,2.7.1无警告
版本低用pip3 install h5py --upgrade 升级

HM2G{YOY3ME8{N10NJ4A~0S.png
我试了print(h5py._version_)没有显示出来版本号
然后我直接升级了h5py,但是升级后再次import h5py还是报一样的告警。
5VD21G6M}5}ZGC{4YXB6SAF.png
请问这是怎么回事啊??谢谢了
回复 支持 反对

使用道具 举报

2

主题

219

帖子

219

积分

版主

Rank: 7Rank: 7Rank: 7

积分
219

热心会员默默耕耘优秀版主

剑心无痕 发表于 2017-12-26 16:34:36 | 显示全部楼层
进阶的小白 发表于 2017-12-26 15:19
我试了print(h5py._version_)没有显示出来版本号
然后我直接升级了h5py,但是升级后再次import h5py还是 ...

前后都是两个_, __version__, 你直接复制我上条命令就行
回复 支持 反对

使用道具 举报

1

主题

7

帖子

7

积分

贫民

积分
7
进阶的小白  楼主| 发表于 2017-12-26 20:12:02 | 显示全部楼层
本帖最后由 进阶的小白 于 2017-12-26 20:13 编辑
剑心无痕 发表于 2017-12-26 16:34
前后都是两个_, __version__, 你直接复制我上条命令就行

UHJ2LIV6YDS1`3UG5TP[PKO.png
看到了版本号,是2.7.1,但是我又关了Python重新打开试了一下,输入import h5py还是会出现告警,请问一下这个该怎么解决啊?,但是就像上面输过一次import h5py,再输第二次就不会告警。
回复 支持 反对

使用道具 举报

1

主题

7

帖子

7

积分

贫民

积分
7
进阶的小白  楼主| 发表于 2017-12-27 21:13:31 | 显示全部楼层
顶一下
回复

使用道具 举报

1

主题

5

帖子

5

积分

贫民

积分
5
yoyoalphax 发表于 2017-12-28 13:17:33 | 显示全部楼层
conda list / pip list,把所有h5的库都清除,然后再pip install,分清pip对应的py版本,别搞错
回复 支持 反对

使用道具 举报

0

主题

1

帖子

1

积分

贫民

积分
1
tfsong 发表于 2018-4-16 19:32:17 | 显示全部楼层
楼主解决了没,我也遇到这样的问题,在ubuntu16 python导入 h5py时遇到,找了很久还是没有解决
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表