找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 152|回复: 10

[求助] pip安装第三方模块报错

2

主题

8

帖子

8

积分

贫民

积分
8
Mi思特陈 发表于 2018-12-1 21:32:42 | 显示全部楼层 |阅读模式
本人新手,最新在学习python,在学习过程中难免设计到要安装第三方模块的问题,但是在使用pip安装第三方模块的时候,总是报错SSL问题和TLS问题,情况如下:
1.png

2.png

3.png

4.png
而且本人的pip已经安装到18.1版本,但是不知道为啥还是不行,目前只能使用豆瓣的第三方模块库,因为豆瓣可以使用http,不校验SSL
5.png

6.png
请各位python大神提供下解决办法!
回复

使用道具 举报

2

主题

8

帖子

8

积分

贫民

积分
8
Mi思特陈  楼主| 发表于 2018-12-2 10:37:25 | 显示全部楼层
咋没人给解答下呢??难道都没遇到过?
回复 支持 反对

使用道具 举报

0

主题

2

帖子

2

积分

贫民

积分
2
120090438 发表于 2018-12-2 21:58:08 | 显示全部楼层
检查下python版本
回复 支持 反对

使用道具 举报

2

主题

8

帖子

8

积分

贫民

积分
8
Mi思特陈  楼主| 发表于 2018-12-2 22:01:49 | 显示全部楼层

1.png
回复 支持 反对

使用道具 举报

3

主题

34

帖子

34

积分

贫民

积分
34
彭国禹 发表于 2018-12-3 09:59:25 | 显示全部楼层
换python3去做?反正新手的话,现在不建议学2了。
回复 支持 反对

使用道具 举报

0

主题

2

帖子

2

积分

贫民

积分
2
120090438 发表于 2018-12-4 21:19:48 | 显示全部楼层
电脑是32还是64的,python版本和第三方库版本也要匹配。有的库不支持32位的操作系统,比如tensorflow
回复 支持 反对

使用道具 举报

1

主题

2

帖子

2

积分

贫民

积分
2
Duaire 发表于 2018-12-7 14:21:39 | 显示全部楼层
如果通过pip命令安装返回提升找不到匹配版本,建议贴主去该库的网站看一下它对应的python版本有哪些,是多少。按道理2.7作为python2的最后版本应该是已经可以被所有python2的库兼容并且有pip安装源的,但是个人建议使用python3。有些库已经可以兼容python2和python3并且也有相应替代新库。
如果是使用window,那么可以直接网上搜索XXX for pythonX.X的安装包,他是exe安装包可以直接解决没有python版本和库没有匹配版本的问题
回复 支持 反对

使用道具 举报

2

主题

8

帖子

8

积分

贫民

积分
8
Mi思特陈  楼主| 发表于 2018-12-11 23:28:31 | 显示全部楼层
彭国禹 发表于 2018-12-3 09:59
换python3去做?反正新手的话,现在不建议学2了。

主要是我们单位现在用的都是python2
回复 支持 反对

使用道具 举报

2

主题

8

帖子

8

积分

贫民

积分
8
Mi思特陈  楼主| 发表于 2018-12-11 23:31:39 | 显示全部楼层
120090438 发表于 2018-12-4 21:19
电脑是32还是64的,python版本和第三方库版本也要匹配。有的库不支持32位的操作系统,比如tensorflow ...

我电脑是64位的,现在我用pycharm也是提供SSL有问题,访问不到https的链接,但是我的电脑直接浏览器打开https的链接是没问题的
回复 支持 反对

使用道具 举报

2

主题

8

帖子

8

积分

贫民

积分
8
Mi思特陈  楼主| 发表于 2018-12-11 23:37:32 | 显示全部楼层
Duaire 发表于 2018-12-7 14:21
如果通过pip命令安装返回提升找不到匹配版本,建议贴主去该库的网站看一下它对应的python版本有哪些,是多 ...

pycharm.png
我现在使用pycharm也是报这个问题,pycharm自动安装的pip都是和python匹配的版本,我现在也不知道该怎么解决了!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表