找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 296|回复: 5

[求助] ora-01882的报错

1

主题

4

帖子

4

积分

贫民

积分
4
jareky 发表于 2018-1-30 08:58:08 | 显示全部楼层 |阅读模式
用python + django调用oracle9i的时候会报ora-01882的错误,调用11g的就不会。因为实际生产用的是9i的数据库,求教各位大神如何解决
回复

使用道具 举报

0

主题

229

帖子

229

积分

侠客

积分
229
sheeboard 发表于 2018-1-30 09:08:22 | 显示全部楼层
数据库驱动版本看看
回复 支持 反对

使用道具 举报

1

主题

4

帖子

4

积分

贫民

积分
4
jareky  楼主| 发表于 2018-1-30 09:10:43 | 显示全部楼层
sheeboard 发表于 2018-1-30 09:08
数据库驱动版本看看

你是指cx_oracle?这个是5.3版本的
回复 支持 反对

使用道具 举报

0

主题

229

帖子

229

积分

侠客

积分
229
sheeboard 发表于 2018-1-30 09:12:15 | 显示全部楼层
是的去官网查这个版本支持哪个版本的oracle
回复 支持 反对

使用道具 举报

1

主题

4

帖子

4

积分

贫民

积分
4
jareky  楼主| 发表于 2018-2-1 16:27:31 | 显示全部楼层
试了多个版本的cx_oracle都不行。看6版本的说明:
Support for Oracle Client 11.2, 12.1 and 12.2. Oracle's standard cross-version interoperability, allows easy upgrades and connectivity to different Oracle Database versions.

Connect to Oracle Database 9.2, 10, 11 or 12 (depending on the Oracle Client version used).

应该是支持的,求各位大神帮忙
回复 支持 反对

使用道具 举报

1

主题

4

帖子

4

积分

贫民

积分
4
jareky  楼主| 发表于 2018-2-9 00:51:06 | 显示全部楼层
后来发现只要把setting.py中的USE_TZ 改成False即可
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表