找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 208|回复: 3

[已回复] 导入 chaco 的部分包是出现import error

6

主题

8

帖子

8

积分

贫民

积分
8
muzili314 发表于 2016-9-27 19:48:43 | 显示全部楼层 |阅读模式
比如 from chaco.ui import * 正确
但是from chaco.shell import * 就会报图示错误
原来的报错是chaco unable to import the image backend for the qt4 toolkit no module named kiwisolver
手动安装
回复

使用道具 举报

47

主题

868

帖子

924

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
924

活跃会员热心会员最佳导师默默耕耘突出贡献优秀版主荣誉管理论坛元老

blueelwang 发表于 2016-9-28 08:23:40 | 显示全部楼层

手动安装一下kiwisolver模块即可
回复 支持 反对

使用道具 举报

6

主题

8

帖子

8

积分

贫民

积分
8
muzili314  楼主| 发表于 2016-9-28 13:32:13 | 显示全部楼层
blueelwang 发表于 2016-9-28 08:23
手动安装一下kiwisolver模块即可

我是手动安装了kiwisolver 但之后又报 can not import PlotWindow的错
回复 支持 反对

使用道具 举报

47

主题

868

帖子

924

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
924

活跃会员热心会员最佳导师默默耕耘突出贡献优秀版主荣誉管理论坛元老

blueelwang 发表于 2016-9-28 19:36:42 | 显示全部楼层
那就再安装一下PlotWindow, 注意版本对应
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表