找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 194|回复: 0

[求助] MAC安装qsci的designer-Qt4Qt5的make && date步骤,提示'QtUiPlugin not found

1

主题

1

帖子

1

积分

贫民

积分
1
shanyaoliu 发表于 2018-1-12 12:48:09 | 显示全部楼层 |阅读模式

MAC上安装qsci的designer-Qt4Qt5的make && date步骤,提示'QtUiPlugin/QtUiPlugin' file not found,已经设置了QT环境变量,在终端上输入qmake -v显示
:QMake version 3.1
Using Qt version 5.8.0 in /Users/victory/Soft/Qt5.8.0/5.8/clang_64/lib


装的是这个版本:QScintilla_gpl-2.10.2


具体错误如下:
/Users/victory/Soft/Qt5.8.0/5.8/clang_64/lib/QtDesigner.framework/Headers/QtDesignerDepends:7:10: fatal error:
'QtUiPlugin/QtUiPlugin' file not found
#include <QtUiPlugin/QtUiPlugin>
^~~~~~~~~~~~~~~~~~~~~~~
1 error generated.
make: *** [qscintillaplugin.o] Error 1


我按照路径/Users/victory/Soft/Qt5.8.0/5.8/clang_64/lib/QtDesigner.framework/Headers/QtDesignerDepends:7:10:找到了这个文件,内容是:

/* This file was generated by qmake with the info from <root>/src/designer/src/lib/lib.pro. */
#ifdef __cplusplus /* create empty PCH in C mode */
#include <QtCore/QtCore>
#include <QtGui/QtGui>
#include <QtWidgets/QtWidgets>
#include <QtXml/QtXml>
#include <QtUiPlugin/QtUiPlugin>
#endif

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表